A lot of API errors with the "Save Post Tool" feature

Hello everyone !
I use on a daily basis a method where I have 7 scrapers with solid 4G proxies. The scrapers are only used for the scraping tools (obviously) that I use manually to retrieve the URLs of very carefully selected IG posts. These posts are then fed into source of the save posts tool of a main account. Then I do the F/UF manually. It’s a bit tedious, but it really work(ed) like a charm and allow(ed) great grow. Since a few days, my main account doesn’t save as many posts as it used to. I saw that I have a lot of API errors now (more erros than successes). I don’t know if the save post featured is now as strongly monitored by IG and restrained in automation like the other features (follow, like, comment, etc) or if it could be something else. Any idea ?

What do those API errors say exactly? Does Jarvee show a red exclamation mark for your Save tool in Tools tab? Also, how many posts does your main account save per day?

1 Like

It’s tough to say anything about it. I assume that you should check what kind of API call errors are you getting. It’s possible that you’ve got blocked from doing those API calls.

1 Like

Hello and thanks for your answer. No exclamation mark no. Only in the “results”, I have only 18 posts saved as usually I ask JV to save 100 per day.

Here is the error message :

2021-05-07 07:43:13.1752 - Error api:3082010A0282010106FFD7E0874567A1F9B6FEC0ECC75592410328917F24F99D919D5BD8A591D587A56EE7531663323DE6201DFD5B76DCD2A991141507465752F3243DAAFD186C5EB7EBD894B23DB81364A850E88404D70A1445BDCD8EE31A1FED033AA34DD41EEC78D5E757C58A8AC5C26BF4336257FC6757EDE4178ED213E474552D3FB97BA7171D840238401DF08220B79D802096CC88A763D9D02E7EBAF8A744CF27293EDEF55AEB0B371488C0BE3EFD9F289D9D0D56E7ABAF1C1A5B6BA8D007447D6637BA3F0E6ACE7B65C58CF2F0CDB501068DCEFC0735C8404B70203010001 for:i.instagram.com val:3082010A02820101009AE66165688BF342E529D2B6A499959D049A729B844733DC5BB8DBF5F0C5CCD6823902F67CAF5611556E006C3DA1969630CFB4A08253D7250C097CAD8BF403A2C8E1A649F3BA573B63874EAD4202F7B81C2D454675E56B67E6225CCF636408BCC0C4D814311C18F7A8EEFEE65091DDEC1B3C0181C3472699E7AD42FDF60AA41B78659B6C24C18B05190FE14FD5B551679DFC23AA2CE02A901A7D29C25A09683CECB03CF4B0B9A996FA4B2135B8231A52AA1A92B66E40FEB39040A5A4F1BCF4966F8EFDB7064FFC8CEF2CEE5208592EBA42B38412B649612F584F6452A8636FE66F81F468FA2FAAE03DA74456B655C523BFD1A2902541827497805113737AE5130203010001
2021-05-07 07:43:32.1897 - XXXXXXXXXXXX GetCollectionDetailsInternal failed with exc:System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure.
at System.Net.TlsStream.EndWrite(IAsyncResult asyncResult)
at System.Net.ConnectStream.WriteHeadersCallback(IAsyncResult ar) Message:One or more errors occurred. StackTrace
Message:One or more errors occurred. StackTrace at System.Threading.Tasks.Task1.GetResultCore(Boolean waitCompletionNotification) at Jarvee.DTO.Services.Instagram.HttpClientService.SendAsync(HttpClient client, HttpRequestMessage request, Int32 count) at Jarvee.DTO.Services.Instagram.HttpClientService.GetInternal[T](String url, SessionData sessionData, String operation, HttpClient client, Int32 counter, Dictionary2 headers, Boolean isExternalclient, Boolean ignoreSuspend, String timeStamp)
Message:An error occurred while sending the request. StackTrace
Message:The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. StackTrace at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
at System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar)
Message:The remote certificate is invalid according to the validation procedure. StackTrace at System.Net.TlsStream.EndWrite(IAsyncResult asyncResult)
at System.Net.ConnectStream.WriteHeadersCallback(IAsyncResult ar)

well, you can test that and see, once the daily period of time when you save posts almost over you can check if you are able to save a post from the embedded browser manually or from the phone just make sure the account is stopped first before you log in from the phone and see if IG is showing any blocks or restrictions.

This morning things are getting even worse. I did what JV support told me (restart software, start stop the Save tool). And as you can see on the attached picture, I get only API errors (still the same). No posts get saved. I tried what you suggested Luca : Saving posts from EB of from Phone (after disabling JV), works like a charm. So It’s maybe a JV issue…

you can let them know that the issue persists and they will probably ask for a TeamViewer session and check the issue directly from your computer.

1 Like

That’s a lot of API errors. Do you use a proxy on that account?

1 Like

Thanks Luca, yes I’m in touch with JV support. Waiting for their answers.

No not for the moment. It’s directly the IP of the VM on AWS. But I’ve used it like this since months without any problem. It’s really the first time. So normally IG bots should know that this behaviour is usual, nothing new…