Facebook Creative Studio non posting on IG

Hi folks, do you have the same issue?
I create a post inside FCS (Facebook Creative Studio) and press the button post. An icon says “posting on IG” but it’s not.

Do u have the same issue? Wandering if all of this may be connected to the latest shitload happening on IG…

Can you possibly post some screenshots

1 Like

Sure mate.
As u can see it says it is publishing but it’s not.

Have you checked on any possible updates?

Something weird happens, I schedule a post, for testing and no problem, then I went for the real post, I upload an image and I try to crop it, nothing worked, just a blank dialog appeared, I tried in different browsers too.

Doesn’t look like a robust tool, really I cannot believe that the developers cannot do a simple and working web application to post in their own platform, this is more than a joke, I know that they outsource most of the development but they don’t have a single PM with 1 neuron working???

Sorry was I was venting…

1 Like