How to avoid error code 508 on JV while sending DMs

Error code: We restrict certain activity to protect our community. Tell us if you think we made a mistake.

I have great spintext ( that’s what I think ), I am using 4G proxies and not running more than 3 accounts on each proxy, Using scraper on another proxy. While some accounts never get this DM specific error while others regularly get hit with this. Do you know how to avoid it?

Every small suggestion is welcome.

4g proxies for DMs? Why!

How many are you sending per day? The limit is somewhere around 70. Keep it around 50 a day. None of my accounts (thousands of them send DMs each day) got such an error. They all run on DC. Sometimes, the account just gets disabled but getting DMs restricted is rare. It can also happen if you are sending them too fast


Yes 4G, because I have my main account on that proxy as well and i don’t want to risk it. 70 Dms per day? that is so amazing. I don’t care about them getting disabled but god knows why I am getting 508. How fast is too fast?

If you are sending one every 30mins, i dont think you will have any problems. just randomise it to keep the average time gap as 30 mins.

1 Like

Do you advise them to run 24/7 because if I send one every 30 minutes I only get to send 48 DMs no? 24 hours * 2 = 48 DMs ?

I give a 6 hour gap. No point in sending Dms at night. Start with 36 a day and then you will get to know how and what to increase. I just dont want to put out my exact settings here. But the gist is randomise the interval for it to remain close to 30. it can be like 10-40 mins.


I understand that. Thanks for the great inputs.

1 Like

Around 70 messages per day, that’s a great result. Are your accounts aged and big account? What proxy provider do you use If I may ask?

Don’t go over 20 DMs per day. Also, try resting those accounts for couple of days, then switch to EB or to API emulation, whatever you are using now and see if it works better with different option selected.


the accounts are resting now and I will update after few days how they perform. Thanks for the tips.

The limit isn’t 70 a day… it wasn’t even 70 a day before they made changes to DMs, it was approx 50. Now with the changes, its approx 35 daily.

Please don’t spread false information, it’s not a good look for the forum.

This is more reliable advice. Listen to this man.

Yes that’s true and even 20 shouldn’t be done from the first day the account need to be warmed up correctly.

1 Like

At first you need to warm the account by increasing the number each day and yes. Use random intervals because this way you can’t be predicted and in this way Instagram won’t flag you. One more advice is to message a mix of your new followers and some random people on your niche chosed by your own criterias. Also be sure that you work with scrapers. I deliver close to 50 DMs each day with my own 4G proxy which I’m about to sell in around 2 weeks :slight_smile:


Try to switch to API full emulation if you keep getting blocked on EB, and check the option Enable contextual actions in Contact > Send Messages tab.

1 Like

Can you explain what contextual action actually does ?

I’m seeing success by adding more scrapers

The contextual action makes the action look more natural, thus helping reduce the blocks. The contextual actions in the Contact tool only works when you’re using API. So, you need to set your account to use API full emulation.


Thank you for letting me know.