Is Google being weird for anyone else?

Idk whasup with this look, this can’t be a new update, I get the same thing for google images too

anyone else or just me :cold_sweat:

Working fine on my end, do you have a User Agent switcher enabled? What browser are you using?

Nope i dont have anything like that enabled, I am using Opera which is kind of an odd browser now that i thnk about it - firefox seems to be working fine

1 Like

Looks like a bunch of plugins and scripting could be disabled, probably a security setting in Opera and the way their browser creates the page when it can’t load the latest compatible code.

I use opera too, but I don’t see anything strange or different than usual.

This is my version btw: 45.0.2552.881

Keeps doing this to me:


im getting the same with opera on my end today

Reminds me of how much i hated opera. It used to be cool, till they switched to chromium and every update breaks something and the UI keeps changing.

I didn’t like chrome, and also didn’t like firefox, but i still stuck with chrome because they are all worse than chrome, even if chrome is bad.

1 Like

definitely agree, opera is good for a while then it just gets unnecessarily weird. I think i might go back to Comodo Ice dragon which worked pretty well for me for a few years

Did this problem get solved? This interface looks like when I use Opera Mini on my iPhone and the “Mini” mode is turned on.
So it looks like a basic mobile interface.

I didn’t really do anything to fix it, Opera just started working again. maybe you need to do an update

1 Like

Yes with opera browser