Question: Setting up own proxy via Centos

I just setup my own proxy on a linux vps via centos but the problem is that it doesn’t connect to all websites. Anyone know why this may be? Is it being blocked certain websites, if so how can i unblock those website?

Ex: Can’t connect to google or instagram but youtube and facebook are fine.

1 Like

What script are you using ?
I recommend tweaking with squid3 and see what results you have.

If you want the lazy version and you have a whole subnet on your hands, you can try Tinyproxy but the bad parts of this is that you will not have the “always active” under connection in header and most social networks check for this as its the first thing to detect proxies. You can config it if you know little if you search 10 minutes on google.

im using this:

I actually been searching for hours but idk what im reading. I did google it and it seems that i should be able to access all website, and if i want to block websites then i can but theres nothing about how to unblock websites.

Im not sure why im able to go on certain website and some websites i cant. I cant use the proxies i set up with mp on centos os. I used centos 7.

Im thinking of trying this:

what you think of that tutorial?

1 Like

Give TinyProxy a try as its very easy to setup

Here is a step-by-step tutorial on how to install it on Ubuntu 14.04

Also for a more secure connection and annonymous here is a configuration file !

1 Like

Thanks. I’ll try out ubuntu then if that don’t work ill try tiny proxy

Try ping to google or Instagram? Maybe your host block the websites.

It works and it doesn’t work. It’s weird. When I ping it doesn’t work. When I load it on my web browser it works. But if I go directly to ig. It doesn’t work. I got to go via Google search.

Also don’t work with mp

I mean ping from your vps, If can’t ping, probably the problem is in your server.

I pinged from my computer. Don’t work.

I’m using digital ocean.

I tried many servers already. Same issues

Oh digitalocean, Try changing /etc/resolv.conf from: nameserver

I am using d.o myself and i have squid setup on Ubuntu, it works like a charm.

what tutorial did you use

do i change it within putty? im a noob.

same as on d.o’s site , its old but still works.

This one?

Did you use centos 7 to do it?

I got stuck on this part. Where do I add the following line? Inside the Cron? Well I added the line but after that, it still doesn’t work. IDK what i did wrong.

Also how do i put a user/pass auth?

I am going crazy…

I tried to install squid on centos multiple times in multiple ways - don’t work

I tried to install squid on ubuntu multiple times in multiple ways - don’t work. Someone tried to help me, and it doesn’t work either.

Now I tried a 3proxy script to install it on my ubuntu and still doesn’t work.

I am using digital ocean, but for some reason. I can’t get it to work. Can someone help?

Which CentOS did you install while following the guide on D.O? 7.3?

I already mentioned that i used Ubuntu with it. Drop me a pm I’ll help.

I’m here. Let me know when you can help with setting it up on ubuntu.

Thank you so much.

what do you want to setup ? squid or 3proxy ?