4G proxy rotation intervals

Hey there,

I started Instagram M/S a couple of months back and been trying stuff and improving my setup.
I have my own 4G Mobile proxies that rotate really fast whenever I want.
I was always doing rotation every 20 minutes and had 15 accounts per proxy, it worked kinda well, although I sometimes got PV and captcha.
But I just think in 20 minutes a lot of accounts will do actions at the same time, so I was wondering:

Should I make 8hour intervals, place 5 accounts on each interval and rotate the ip once the next accounts will start doing actions?

Or would it be better to just rotate every 5 or 3 minutes?

My 4G IPs, everytime they rotate, they change the location to a different city in a range of around 100km. So I feel like if I change too fast too many times, even if there are few accounts doing a few actions per ip, it will just trigger Instagram.

Also, I make my own accounts, with different phone numbers, manually and they warm up for very long.

@Boris mentioned this in the past, I think it could help:

“The more accounts on a single 4G connection, the higher the necessity to rotate (anywhere between 30-90min). We never rotate in the same intervals, it is always a value of a random spread e.g. between 36 and 48min”

As for the location, you might want to check out I think i finally got it - #10 by Boris

Hi, i did create my own 4G proxy. However, i couln’t find the script where i can rotate it. Where did you find that script ? did you created yourself?

I used proxidize. But its paid to do rotation unfortunately.

I just made my first 4G proxy with a raspberry and I just use the crontab command to reboot the raspberry in intervals of 8 hours automatically. Haven’t found any other way yet. You could implement a script in 3proxy to reboot the dongle, but I didn’t find the right code for my dongle yet so I went with the crontab method.

I thought about but 600$ yearly is just too much for a code! i would just use proxy providers

You can use the free verison. You don’t need to rotate unless you are running lots of accounts or account creation.

I now run 10 accounts per 4g with no rotation and have better results than when I was rotating. This was just my experience though.

i think we used the same code from blackhat hahah but you were smarter by using the crontab. i dont know about it :smiley: `can you show me the command.
There is a guy there promised to sell me the script but he just vanished :smirk:

1 Like

you think so! im just not the proxy expert.
tbh i am running 14 on a paid 4g provider and its working also fine. but i am sure the pool is too risky to keep my account there so i would love to have my own. and as normal phone moves, the ip should rotate no?

In my case, we first used the free version of Proxidize, to rotate, it was a kinda weird method, we put a servo that every X time would simply switch off and on the USB hub where the dongles were connected. The servo was using arduino so it was easy to confgure.
I don’t know to code so I have to find solutions that way :sweat_smile:

1 Like

That is also an option, either turn off the usb port or the whole device like I did :smiley:

Yes thats like the only useful guide I could find for my purpose. I am thinking about making a thread how I managed to set this up because I had lots of pains which weren’t explained in the guide :slight_smile:

Search for “cronjob raspberry” in Google - you will find lots of guides!

1 Like

would love to see it. because even that i am getting an IP, there is a small error!

1 Like

can you explain which error?

1 Like

when i run $ sudo ./startproxy.sh

I get this:

Let’s setup the IP
Let’s setup the routes for the proxy
Error: either “to” is duplicate, or “gw1” is a garbage.
Error: Nexthop has invalid gateway.
Let’s start the proxy

when i check, i actually see that the IP is changed!!

My advice is to see the costs using your own vs using someone elses. Then test to see how good the ips are by creating accounts.

I live in NZ and had a decent sized farm. I rotated proxies every 20min and found myself with useless proxies as I had somehow fried the ips in my area.

I realized the ip pool in my area must be small compared to bigger countries. This was when I stopped using my own. Worked well at the start but running hundreds of accounts, creating etc killed everything.

There is a mistake in the guide, I had the same problem.

You have to go back in the script with:
sudo nano startproxy.sh

Then you need to add table in front of gw1 because its missing in the code! Make sure its in every line like this:

sudo echo "Let's setup the routes for the proxy"
sudo ip route add dev usb0 src table gw1
sudo ip route add default via dev usb0 table gw1
sudo ip rule add from table gw1
sudo ip rule add to table gw1

This should fix the gw1 is a garbage error.

The nexthop error can be fixed by entering the right IP adress of your dongle.
I also thought that you could use the IP gateway given in the script, but you need to enter the same IP adress like when you try to get on the dongle interface.
For my dongle HUAWEI E8372h-320 its instead of

So make sure you change every IP in the script with the one of your dongle.

Hope this helps :slight_smile:


Thanks a lot for the info :pray:

i acutally found 2 guides online and my script looks exactly like yours with one different.
when i run ifconfig, i dont get anything called usb0 but what i get is eth1. So i changed the script accordingly.

sudo nano 5.4 startproxy.sh

sudo echo “Let’s setup the IP”
sudo ifconfig eth1
sleep 2

sudo echo “Let’s setup the routes for the proxy”
sudo ip route add dev eth1 src gw1
sudo ip route add default via dev eth1 table gw1
sudo ip rule add from table gw1
sudo ip rule add to table gw1
sleep 5

sudo echo "Let’s start the proxy "
sudo 3proxy /home/pi/3proxy.cfg

Regarding the Getaway, you are right. at the begnning i had a problem with it. but then i change the whole router getaway so now i have all the same :smiley:

Do you have any idea why i still have the error ?
Thanks a lot

Had this problem too. I thought it had something to do with the mode the dongle is running on.

In the script it sais it should be 1405 or 1403 so I tried to switch it with a modeswitch command, because my mode was 14db. But it didnt seem to work since it was still recognized as eth1.
I also tried the same thing you did and changed every usb0 to eth1 but this didnt work too.

This was the dongle I used: HUAWEI E3372h-320

I then tried it with another dongle: HUAWEI E8372h-320

The mode was still on 14db but this time the raspberry categorized it as usb. I dont know why. Maybe it has something to do with the functions of the dongle, since the E8372h has more features and the raspberry needs to configure it as usb.

NOTE: Theres still table gw1 missing in the first line of ip route. You may double check in your startproxy.sh :slight_smile:

1 Like

Thanks a lot of your help. Tbh i also think my dongle has problem which means 40€ just wasted :smiley:
i will also check my startproxy.sh :slight_smile: thank you

1 Like