Using your home IP as a residential proxy with a Raspbery

I’d buy one for sure

Just ran through the tutorial and it works!

thank you @dimitri

Allowed me to move an important account off a datacenter proxy and onto a home one.

not gonna be easy


Yeah tell me about it, I’ve been trying for days and have had no luck. When I try to specify the internal IP address as the RPi ethernet and the external as RPi wifi then everything works fine but when I put the external IP address as the 3G dongle then it acts as if it has no active connection to the internet. I have tested the dongle, it does have a 3G connection so my assumption was that I need some sort of routing table since the 3G dongle is on another subnet.

I don’t know much about IP routing and IP tables but I’ve Googled it a bit and any route that I set up just doesn’t seem to work. Not even sure how to properly troubleshoot it. While researching I read in some places that the huawei 3G dongles have 2 different modes, HiLink (router Mode) and Stick mode (modem mode). Supposedly the dongles are supposed to be in modem mode but by default are in HiLink mode. You know it is in HiLink mode if you can access If it is in router mode then this kind of makes sense as to why it is not working as I cannot set up any route or port forwarding or anything on the dongles router, so it would not know where to send the packets so it just drops them instead. I’d assume that this routing would not be needed in modem mode because it would be just 1 external connection, no routing needed, right?

I spent ages trying to figure out how to connect the dongle in modem mode but when I finally got it to switch there was no longer an interface for the dongle. I have tried setting up a new interface for it using many different guides but could not get it to work. I also tried using wvdial and managed to create an interface with this at one point, had an IP address and all but still no active internet connection, couldn’t browse the web at all.

I’m at a bit of a loss with it now and can’t really think of what else to try so if anyone has any suggestions, please do let me know.

1 Like

anybody has experience to build many mobile proxies on windows and would like to help + earn some $$$/get free mobile modems/get mobile proxy for some time? :slight_smile:

Maybe get inspired by this Thread?

i’m working on that, hope to get them soon

1 Like

I have been stuck for days.
I managed to get this to work succesfully from browser, both local and remote. If i check the proxy with a proxy checker it successfully say that it works, BUT if i try to use it on my vps, most of the times i get a 502 error, i can do some action, like some F/UF, but can’t add an account, or many action fail with this error. Ports are open on the server and all others proxy always worked without any problem. Any suggestion?

1 Like

youre a trooper for sticking it out man. I hope you can get some help and figure it out!


Thanks @dimitri exceptional work!!!

Thank you so much, it works like a charm :facepunch:

Hey @dimitri Thanks for the guide. I’ve made it possible on the vm. But I have some questions.

  1. I have installed Ubuntu OS > VirtualBox > AntixOS and here I have done all the steps you’ve written. Now, How do I make sure that those proxies can be used outside of the Virtual Box?

  2. You have mentioned about one USB Stick. What if we want to handle multiple USB Sticks? How would you do that? Since, RaspberryPi has a lot of ports not just one. How do we setup for that?

Thanks. :slight_smile:

Thank you for this wonderful guide, might give it a try soon :slight_smile:

Does anyone know how well this work with multiple static residential ips? i have access to them through my isp for about $2 a piece and would love to set this up but im not sure.

Hello Dimitri, i stuck at sudo sh /etc/3proxy/scripts/rc.d/ start . It says access denied. I used command sudo chmod 700 3proxy.cfg but there was no reply, just gave me a new command line after that. Do you have any idea why? Thanks in advance

I want to ask how many ig accounts I can run with a Raspberry

Any tutorial on this kind of setup?How can I configure 3proxy to use 1 dongle per user?

Very nice posting, thank you!

any info how i can setup with dongle?

Been using this method since February and it’s a great reliable setup, well worth the effort.
I am trying to set up a raspberry pi with a tethered android mobile for 3G access instead of using the residential IP. Been trying for a few days with no success, tried an iphone too. Planning on ordering a Huawei E3372 dongle or two as soon as I’m happy with the setup.
Everything works perfectly using the residential IP for internal and external, but when I switch to the mobile device for external I get a proxy error in J.
Mobile internet is working as I can resolve and ping an address using
ping -I usb0


pidfile /etc/3proxy/
nscache 65536
timeouts 1 5 30 60 180 1800 15 60
users root:CL:password removed
#log /var/log/3proxy.log D
#logformat “- +_L%t.%. %N.%p %E %U %C:%c %R:%r %O %I %h %T”
archiver rar rar a -df -inul %A %F
rotate 30
auth strong
allow root
#proxy -p4596 -a -i192.168.0.32 -e192.168.0.32
proxy -p4596 -a -i192.168.0.32 -e192.168.42.190


eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::8e95:7402:85cd:44fe prefixlen 64 scopeid 0x20
ether b8:27:eb:25:92:0b txqueuelen 1000 (Ethernet)
RX packets 606 bytes 58721 (57.3 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 364 bytes 66999 (65.4 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::afc6:c086:d2a:66fe prefixlen 64 scopeid 0x20
ether 9a:09:25:e3:cc:66 txqueuelen 1000 (Ethernet)
RX packets 41 bytes 3587 (3.5 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 68 bytes 11839 (11.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether b8:27:eb:70:c7:5e txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

If anyone can help it would be much appreciated! I’ve read all the documentation and everything I can find but no joy so far.