Using your home IP as a residential proxy with a Raspbery


#81

could you also include your full 3proxy config, and ifconfig output in your post? Also please be more specific if you can (implying you know what’s not working)


#82

Finally, my own VA to answer my questions :joy:


#83

Hi. I’ll do my best :smiley:
My current 3proxy.cfg:

daemon

pidfile /etc/3proxy/3proxy.pid

nserver 208.67.222.222
nserver 208.67.220.220

nscache 65536

timeouts 1 5 30 60 180 1800 15 60

users root:CL:pass

#log /var/log/3proxy.log D

#logformat "- +_L%t.%. %N.%p %E %U %C:%c %R:%r %O %I %h %T"

archiver rar rar a -df -inul %A %F

rotate 30

auth strong
allow root

proxy -p3129 -e192.168.8.100

and here my ifconf:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.2.107  netmask 255.255.255.0  broadcast 192.168.2.255
        inet6 fe80::c1:c290:d0cc:9f3e  prefixlen 64  scopeid 0x20<link>
        inet6 2003:e5:ebc2:8993:3ba9:c22c:f23a:4b5a  prefixlen 64  scopeid 0x0<global>
        ether b8:27:eb:71:a3:09  txqueuelen 1000  (Ethernet)
        RX packets 8900  bytes 12984686 (12.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2929  bytes 500873 (489.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.8.100  netmask 255.255.255.0  broadcast 192.168.8.255
        inet6 fe80::4739:7a8d:c878:99a9  prefixlen 64  scopeid 0x20<link>
        ether 00:1e:10:1f:00:00  txqueuelen 1000  (Ethernet)
        RX packets 171  bytes 77934 (76.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 33  bytes 5149 (5.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Lokale Schleife)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth0 is my home ip and eth1 my 3G

Finally, my own VA to answer my questions :joy:

haha :joy:


#84

ah and whats not working:
When I connect to my proxy, I get a “Connection can’t be established” message.

If I just use:
proxy -p3129 -a

the proxy work but of course it uses my home ip and not my 3G.


#85

Correct syntax would be -
proxy -n -a -4 -i192.168.2.107 -e192.168.8.100 -p1111


#86

thanks. i tried but it still doesn’t work. now I get a network timeout

i enabled logs and:

1535046292.329 PROXY.3129 00000 - 192.168.2.107:3129 192.168.8.100:0 0 0 0 Accepting_connections_[3551/1996162160]
1535046293.863 PROXY.3129 00006 root xx.xxx.xx.xx:60357 0.0.0.0:0 0 0 0 CONNECT_getpocket.cdn.mozilla.net:443_HTTP/1.1
1535046295.576 PROXY.3129 00004 - xx.xxx.xx.xx:60358 0.0.0.0:0 0 0 0 CONNECT_www.wieistmeineip.de:443_HTTP/1.1

*xx.xxx.xx.xx is my residental ip


#87

Why would it not just be the below?

proxy -p3128 -a -i192.168.8.100 -e192.168.8.100


#88

You need to enable (if you didn’t) port forwarding in your router for 192.168.2.107 to the desire port. Otherwise you won’t get any access to www from your dongle exernal IP.


#89

Because you will connect to 3g through you main internet connection.
@iam.evo are you testing this from local machine?
try doing wget -X http://root:pass@192.168.2.107:3128 http:google.com on your pie

Also are you sure your 4g modem is working?
try making a wget -I eth1 http://google.com (to see if your modem is working)


#90

Hi, i made something similar last week, here the setup:

  • PC with MP
  • 15x VM (squid inside, basic option, allow localhost)
  • 15x 3G USB connection

Simply the VM took the signal from MP (proxy with internal IP) and then let it go out from the 3G, i had different provider for the 3G SIM, like 7 from a provider and 8 from another, they were 15 sims and 15 VMs.
So 1 sim x 1 vm x 1/2 acc.

My problem is that even they system is right i still get blocks from IG, with all the sim - account (2xsim+vm, test even 1xsim+vm).
Even with just one 3G SIM + VM i get blocks.
IG accounts are really good, setting too. I have other proxy (not scalable) and they work really good, no blocks.

  • I got new account (good provider, is the same as the other that are working)
  • Fresh 3G (no static IP, it change every day) SIM
  • New VM, all different. IPs was detected like home connection/normal mobile.

Anyone has a solution that can help me?
Thanks in advance!


#91

I got:
Starting 3Proxy
/etc/3proxy/scripts/rc.d/proxy.sh: 15: /etc/3proxy/scripts/rc.d/proxy.sh: /etc/3proxy/3proxy.cfg: not found

Obviously proxy didnt work. any ideas?

@iam.evo @dimitri


#92

The script cannot start the 3proxy executable. So the output of the script will be a lot of nonsense.

You probably did something wrong compiling 3proxy.


#93

Can we use putty to connect raspbery, instead of doing port forwarding in modem/router? since I’m not using modem/router for my main laptop, I’m using mobile wifi hotspot, and on that I don’t know/may be not possible to forward port.


#94

I don’t believe that you will be able to get that to work. You have to enable port forwarding in the router, and you have to connect the Raspberry with that router. If you cannot enable port forwarding it will not work.


#95

At first I did not understand why you’re using router? Is it for only connection with rasperberry? I mean so that you can execute your command via SSH shell? If it is only that then I think putty is also way to connect that. I already mention putty tutotrial on my above reply. I have used putty earlier and I think it is easist way to connect with raspeberry. But I am not sure that weather proxy created on raspeberry will work automatically or not, because it is not connected with my network. So I think you want to say router is necessary to work proxy. Sorry I am totally noob at network.


#96

You still get blocks? What are your automation settings…?


#97

Yes, I make less than 60 follow a day…
Fresh account (new, created on that connection one month ago), account is not the problem cause I tried it after on a home connection and it worked well.


#98

Hi Dimitri, hi everyone
Please help me
I bought 10 dongles, 1 hub and Raspberry
Please correct me if I’m wrong
As I think

  • 10 dongles will put to 1 hub, Hub will be connected to Raspberry USB port
  • My Social Media Software will have same internal network with raspberry

But I wonder
Raspberry have only 1 internal IP, how can I config and use in SocialMedia Software with that 10 dongles
Can I config and use proxy as
internalIPraspberry:3319
internalIPraspberry:3320

internalIPraspberry:3329
Thank you! I still don’t know how to config and use proxies with my 10, 20 dongles


#101

Vey interesting, i have one proxy working currently, as a reverse proxy from my vps running Jarvee, it’s working great, but i still struggle to allow a second dongle on the setup… There is a thread there I can’t read because i don’t have high enough level, i guess it approach the issue similarly to your link.


#102

Is there any reason you deleted your previous posts?